[解決]Advanced Custom Fields4.xにアップデートするとアドオンが動かなくなるから気をつけて

Article

schedule2013.04.03

visibility2578

ワードプレスでカスタムフィールドを簡単に扱えるプラグイン「Advanced Custom Fields」がメジャーアップデートして4.0になりました。

有料アドオンが止まってる…

早速アップデートしてフィールドグループの編集画面を見てみると、有料で購入した「繰り返しフィールド(repeater-field)」を使っている部分が存在しないフィールドタイプということでエラーが起きていました。
そこで「Advanced Custom Fields」の管理画面の「Add-Ons」項目をみてみると
acf01
アクティベートしていた、繰り返しフィールドが認識されていない。

原因は?

その原因として、以前はアクティベートコードを入力すれば、認証される形をとっていたのですがWordpressの設計思想に則ってアドオン用のプラグインを別途インストールする形に変更したようです。
ですので、早速繰り返しフィールド用のプラグインをダウンロードしましょう。
当然以前に購入している方は無料でダウンロード出来ます。

アドオンを有効にするには

先ほどのアドオン管理画面の「here」かhttp://www.advancedcustomfields.com/add-ons-download/へアクセスして、
acf02
以前購入した時のアクティベートコードを入力すればダウンロードが始まります。
ダウンロードしたacf-repeater.zipを解凍し、acf-repeaterフォルダをワードプレスのpluginsフォルダにFTP等でアップロードすれば良いのですが、その際私のacf-repeaterフォルダには「-」という名前のフォルダが入っていました。
その中にPHP等のファイルが入っていたのですが、その状態ですとアップロードしてもプラグインを認識しないので「-」フォルダから中身を1階層上に出して、アップロードして下さい。
そうすればWordpressのプラグイン画面から「Advanced Custom Fields: Repeater Field」というプラグインが見つかると思うので、それを有効化すれば完了です。

他の方法

方法としてはwp-contentの何処かにアップロードしてfunctions.phpから呼び出す方法もあるみたいです。
プラグイン内のreadme.txtより

1. Copy the ‘acf-repeater’ folder into your theme folder (can use sub folders)
   * You can place the folder anywhere inside the ‘wp-content’ directory
2. Edit your functions.php file and add the following code to include the field:

add_action('acf/register_fields', 'my_register_fields');

function my_register_fields()
{
    include_once('acf-repeater/repeater.php');
}

3. Make sure the path is correct to include the repeater.php file

気をつけよう

4.0になり機能の追加も多い様ですが、仕様の変更も多いようですね。

バージョン3から4への変更点
http://www.advancedcustomfields.com/resources/getting-started/migrating-from-v3-to-v4/

クライアント向けで使われている方も多いプラグインだと思いますので、アップデートは慎重に行ったほうが良いかもしれませんね。

コメントを残す

 

2014 © Webgoto